Weboldalak PHP 7.2 vagy alacsonyabb PHP verzióval mysql adatbázishoz kapcsolódás sikertelen MariaDB v10.2.35 vagy v10.3.26 -ra frissítés után: Malformed communication packet

Hibaüzenet jelenhet meg azoknál a weboldalaknál, amelyek PHP7.2 vagy attól alacsonyabb PHP verziót használnak MariaDB v10.2.35 vagy v10.3.26 verziókkal:
SQLSTATE[HY000]: General error: 1835 Malformed communication packet

A hiba okát a fejlesztők jelenleg vizsgálják.

Az eddig ismert egyetlen megoldás a kliens oldalon a helyzet rendezésére, a PHP verzió váltása PHP7.3 vagy magasabb verzióra. Ezt CPanelen a MultiPHP Managerben lehet megtenni.

A PHP7.1 és az azelőtti verziók már nem támogatottak, ( https://www.php.net/eol.php ). Hivatalos javítás várhatóan nem érkezik más probléma esetén ezekhez a verziókhoz. Emiatt ezeknél a verzióknál ettől függetlenül is javasolt a PHP7.3 vagy PHP7.4 -re váltás.